Episodes
bonapa1856 said over 1 year ago on Deploying to Amazon Linux 2 :
According to eb-engine.logs It seems like I don't have yarn. But when I do yarn --version on my machine it show:
$ yarn --version
[DEPRECATION] The trollop gem has been renamed to optimist and will no longer be supported. Please switch to optimist as soon as possible.
Yarn v0.1.1 2011 Jesper Kjeldgaard
Upon doing rails assets:precompile

 rails assets:precompile
Traceback (most recent call last):
        4: from /home/pop/.rvm/gems/ruby-2.7.2/bin/ruby_executable_hooks:22:in `<main>'
        3: from /home/pop/.rvm/gems/ruby-2.7.2/bin/ruby_executable_hooks:22:in `eval'
        2: from /home/pop/.rvm/gems/ruby-2.7.2/bin/yarn:23:in `<main>'
        1: from /home/pop/.rvm/gems/ruby-2.7.2/gems/bundler-2.2.11/lib/bundler/rubygems_integration.rb:390:in `block in replace_bin_path'
/home/pop/.rvm/gems/ruby-2.7.2/gems/bundler-2.2.11/lib/bundler/rubygems_integration.rb:362:in `block in replace_bin_path': can't find executable yarn for gem yarn. yarn is not currently included in the bundle, perhaps you meant to add it to your Gemfile? (Gem::Exception)
Yarn not installed. Please download and install Yarn from https://yarnpkg.com/lang/en/docs/install/
Exiting!

What could be the problem? As is it not letting me deploy?